[SinusBot] Problem

Witam,
chciałem zainstalować bota sinusbot na moim serwerze VPS. Parę razy już go instalowałem i wszystko działało, a teraz mam problem. Instalowałem bota 2 sposobami:

Też tak kiedyś miałem.
Zainstalowałem bota “na czysto”, w innej lokalizacji niż /opt/ts3soundboard/ i zgodnie z poradnikiem MusicBot - Czyli jak zainstalować SinusBot z youtube-dl i obsługą klienta TS 3.1.x , podmieniając tylko lokalizację i zadziałało :smiley:
Spróbuj może też zainsstalować inną wersję.

Czyli zainstalować gdzie indziej, a nie w /opt/ts3soundboard ?

Dokładnie tak, ja najpierw miałem w /home/sinusbot bo miał własne konto, a potem w folderze /opt/sinusbot/
nie wiem, jak to mi zadziałało, ale działa do dzisiaj

@szymhal Dodam od siebie że chyba wersje wcześniejsze niż 0.9.15 mowa o beta chyba już nie będą działać ja tak miałem po reboot KVM sinusbot nie chciał się odpalić dopiero po postawieniu 0.9.15 wszystko wróciło do normy. a tutaj link do nowej bety: https://www.sinusbot.com/pre/sinusbot-0.9.15-257e541.tar.bz2

Wszystko śmiga.
A wiecie może jak zrobić tak, aby bot grał streamy?
Np,: Stream Polskiej Stacji nie działa, wiecie jak to zrobić żeby działało?

Do teraz używałem botów do supportu i innych, a sinusboty grające na ts3index kupowałem, wiecie jak takie zrobić? Dzięki z góry za podpowiedź :slight_smile:

http://www.listenlive.eu/poland.html
pobierasz plik pod winampa, edytujesz notatanikiem, kopiujesz link i dodajesz do bota

To już chyba nie odpalisz w sinusbot, nawet nie da rady wyciągnąć nic, wszystko we flashu.

a żeby odpalać muzykę z youtuba?

https://forum.sinusbot.com/threads/english-german-linux-how-to-install-youtube-dl-with-the-bot.129/

Ponawiam temat, bot znowu nie chce się uruchomić.
otwieram screeena:
screen -S Ts3Bot
Wpisuję komende:
./sinusbot -RunningAsRootIsEvilAndIKnowThat

Uzywam tej wersji:
https://www.sinusbot.com/pre/sinusbot-0.9.15-257e541.tar.bz2

Wpisuje ./sinusbot. Nic się nie wyświetla w konsoli i żaden proces się nie odpala. Używałem instrukcji z: MusicBot - Czyli jak zainstalować SinusBot z youtube-dl i obsługą klienta TS 3.1.x

Najnowsza wersja https://www.sinusbot.com/pre/sinusbot-0.9.16-10f0fad.tar.bz2 wydana jakieś 12 min. temu :slight_smile:

od którejś wersji już nie pamiętam której jak się starsza rozłączy z serwerem to nie che się połączyć i trzeba nową postawić bynajmniej ja tak miałem kilka razy.

Tak kojarzę ten błąd, często się z nim spotykałem :stuck_out_tongue:

Jak znajdę czas zaktualizuje poradnik do aktualnej wersji.

Da się jakoś zaktualizować sinusa na najnowszą wersję bez usuwania plików i zbędnego mieszania w nich? Bo wiem że się da poprzez pozostawienie folderu data czy coś, ale może jakaś komenda ./sinusbot -ForceUpdate czy coś?

pobierasz do siebie na kompa, wypakowujesz, zatrzymujesz sinusbot, i kopiujesz tam gdzie masz sinusbota, uruchamiasz sinusbot

proste :slight_smile:

@LinGruby
Wystarczy skopiować sam plik sinusbot czy wszystko trzeba?

wszystko no i zawartość katalogu plugin do ts w plugins

Na przyszłość polecam ten sposób:


Wygodny i zautomatyzowany :wink: