Rozdzielenie dedyka na VPS'y OpenVZ


#1

Witajcie.
Korzystając z poradnika


chciałem podzielić dedyka na mniejsze kontenery, jednakże gdy postawiłem takowy z systemem Ubuntu to jest tak jak nie byłoby tam internetu.
Dopiero się uczę jeżeli chodzi o takie sprawy i jestem całkiem w tym zielony. :confused:

Logi (apt-get upgrade):

  Err:1 http://archive.canonical.com/ubuntu xenial InRelease
  Temporary failure resolving 'archive.canonical.com'
Err:2 http://archive.ubuntu.com/ubuntu xenial InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Err:3 http://security.ubuntu.com/ubuntu xenial-security InRelease
  Temporary failure resolving 'security.ubuntu.com'
Err:4 http://archive.ubuntu.com/ubuntu xenial-updates InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/xenial/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/InRelease  Temporary failure resolving 'security.ubuntu.com'
W: Failed to fetch http://archive.canonical.com/ubuntu/dists/xenial/InRelease  Temporary failure resolving 'archive.canonical.com'

#2

Czy posiadasz poprawnie skonfigurowane serwery DNS w pliku /etc/resolv.conf?


#3
; generated by /sbin/dhclient-script
search MH-PXE pl
nameserver 8.8.8.8

Wydaje mi się że jest dobrze.


#4

Ustawiłeś to w kontenerze czy fizycznym hoście?


#5

W kontenerze jak i fizycznym hoście.


#6

Komunikacja bez użycia DNS działa prawidłowo?

ping 8.8.8.8

Ustawiałeś jakiś firewall?


#7
root@localhost:/# ping 8.8.8.8
connect: Network is unreachable

Nie ustawiałem żadnego FireWalla.


#8

Pokaż plik /etc/network/interfaces. Jeżeli go nie masz skonfiguruj go według wzoru:

auto lo eth0
iface lo inet loopback
iface eth0 inet static
    address ADRES_IP
    netmask MASKA_SIECIOWA
    broadcast ADRES_BROADCAST
    gateway BRAMA_DOMYSLNA

#9

Nadal nie działa. Z tego co widzę nie działa Serwis “networking”:

   Active: failed (Result: exit-code) since Tue 2018-04-03 16:12:50 EDT; 6s ago
     Docs: man:interfaces(5)
  Process: 409 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
  Process: 404 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environ
 Main PID: 409 (code=exited, status=1/FAILURE)

Apr 03 16:12:50 localhost.localdomain systemd[1]: Starting Raise network interfaces...
Apr 03 16:12:50 localhost.localdomain ifup[409]: Cannot find device "eth0"
Apr 03 16:12:50 localhost.localdomain ifup[409]: Failed to bring up eth0.
Apr 03 16:12:50 localhost.localdomain systemd[1]: networking.service: Main process exited, code=exited, stat
Apr 03 16:12:50 localhost.localdomain systemd[1]: Failed to start Raise network interfaces.
Apr 03 16:12:50 localhost.localdomain systemd[1]: networking.service: Unit entered failed state.
Apr 03 16:12:50 localhost.localdomain systemd[1]: networking.service: Failed with result 'exit-code'.

Jakieś pomysły?


#10

Hm, jedyne co mi przychodzi do głowy to:

vzctl set KONTENER --ipadd ADRES_IP --save

No i wzór konfiguracji który wyżej podałem może być troche zły, pisałem z pamięci a nie siedzę na codzień na GNU/Linux, zedytowałem go troszkę.


#11

W dalszym ciągu nic.
Może podzielić go jakimś innym sposobem? :confused:


#12

Może to głupie, ale spróbuj zmienić nazwę interfejsu z eth0 na ens18, nie znam się zbytnio na Twoim problemie ale nazwa eth0 kojarzy mi się raczej ze starszymi wydaniami debianopochodnych