Problem z kolorami npc itp

Witam, mam problem z serwerem, ponieważ korzystając z citizens po stworzeniu npc - ma ładny kolorek, ale po zrestartowaniu serwera jego nazwa zmienia się na “&eNazwa” lub “??Nazwa” lub “?eNazwa” i niestety przestaje spełniać potrzebną mi funkcję… Bardzo mi to przeszkadza, problem nie dotyczy tylko npc ale też niektóre pluginy przestały mieć kolorowe napisy :frowning:

Za pewne zamiast ? ma być §, co oznacza kolorek w MC (Znaczek & to tylko zamiennik dla klienta MC). Inne pluginy przestały działać? Aktualizowałeś silnik?
Jest to ewidentnie błąd w wczytywaniu jakiegoś configu, gdzie § oznacza kolorek i takowy kolor nie ładuje się. Spróbowałeś np. u kolegi zobaczyć czy z innego komputera i czy ma tak samo? Może to błąd resourcepacka.
Jakieś logi? Podeślij jak masz :slight_smile:

zawsze pisałem /npc create &eBezi i było ok
widziałem żółtego Bezi’ego
i wszyscy tak widzą dopóki nie zrestartuje serwera wtedy pojawia się “&eBezi” a w /npc list kolor normalnie sie wyświetla…
Silnik przekopiowany z innego hostingu, cały serwer wrzucony z innego hostingu, to nie jest wina resoursepacka’

Pliki powinny mieć odpowiednie kodowanie.

Bez sensu, a samemu pobrać nie można :P?
http://tcpr.ca/downloads/spigot

A co mi ma mówić to że pliki powinny mieć odpowiednie kodowanie?

kopiowałem wszystko z innego hostingu bo mówili że wywala serwer z powodu moich pluginów i skryptów a tu jakoś nie wywala :wink:


Polecam kodowanie utf8 :slight_smile:

Serio masz mnie aż za takiego idiotę? Wiem co to kodowanie/zestaw znaków tylko za ciula nie wiem gdzie to się ustawia i o tym napisałem ten temat a tłumaczysz mi wszystko prócz tego co jest mi potrzebne, no wielkie dzięki

Spokojniej, musisz po prostu pisać bardziej sprecyzowane zdania, które pozwolą na zrozumienie.

Najprościej jest przy zapisywaniu pliku.

1 polubienie

suuper, ale jakiego pliku? ;.

  1. Wyłącz serwer
  2. Zmień kodowanie plugins/Citizens/saves.yml
  3. Włącz serwer

ciesz się, że może działa