Problem z bazą danych i AuthMe

Witam,
Mam problem podczas próby połączenia się AuthMe z bazą danych. AuthMe jest skonfigurowany poprawnie. Baza danych znajduje się na tym samym VPS.

[20:50:47] [Server thread/INFO]: [AuthMe] Enabling AuthMe v5.5.1-SNAPSHOT-b2200
[20:50:48] [Server thread/INFO]: [AuthMe] Connection arguments loaded, Hikari ConnectionPool ready!
[20:50:48] [Server thread/WARN]: [Server thread] INFO fr.xephi.authme.libs.com.zaxxer.hikari.HikariDataSource - AuthMeMYSQLPool - Starting…
[20:50:49] [Server thread/WARN]: [Server thread] ERROR fr.xephi.authme.libs.com.zaxxer.hikari.pool.HikariPool - AuthMeMYSQLPool - Exception during pool initialization.
[20:50:49] [Server thread/WARN]: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
[20:50:49] [Server thread/WARN]:
[20:50:49] [Server thread/WARN]: The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
[20:50:49] [Server thread/WARN]: at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
[20:50:49] [Server thread/WARN]: at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
[20:50:49] [Server thread/WARN]: at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
[20:50:49] [Server thread/WARN]: at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.Util.handleNewInstance(Util.java:425)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:990)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.MysqlIO.(MysqlIO.java:342)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.ConnectionImpl.coreConnect(ConnectionImpl.java:2197)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.ConnectionImpl.connectOneTryOnly(ConnectionImpl.java:2230)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2025)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.ConnectionImpl.(ConnectionImpl.java:778)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.JDBC4Connection.(JDBC4Connection.java:47)
[20:50:49] [Server thread/WARN]: at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
[20:50:49] [Server thread/WARN]: at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
[20:50:49] [Server thread/WARN]: at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
[20:50:49] [Server thread/WARN]: at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.Util.handleNewInstance(Util.java:425)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:386)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:330)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:138)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.com.zaxxer.hikari.pool.PoolBase.newConnection(PoolBase.java:353)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.com.zaxxer.hikari.pool.PoolBase.newPoolEntry(PoolBase.java:201)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.com.zaxxer.hikari.pool.HikariPool.createPoolEntry(HikariPool.java:473)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.com.zaxxer.hikari.pool.HikariPool.checkFailFast(HikariPool.java:562)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.com.zaxxer.hikari.pool.HikariPool.(HikariPool.java:115)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.com.zaxxer.hikari.HikariDataSource.getConnection(HikariDataSource.java:112)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.datasource.MySQL.getConnection(MySQL.java:156)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.datasource.MySQL.checkTablesAndColumns(MySQL.java:163)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.datasource.MySQL.(MySQL.java:71)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.initialization.DataSourceProvider.createDataSource(DataSourceProvider.java:66)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.initialization.DataSourceProvider.get(DataSourceProvider.java:47)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.initialization.DataSourceProvider.get(DataSourceProvider.java:25)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.ch.jalu.injector.handlers.instantiation.ProviderHandler$InstantiationByProviderClass.instantiateWith(ProviderHandler.java:129)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolveContext(InjectorImpl.java:164)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.resolve(InjectorImpl.java:133)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.libs.ch.jalu.injector.InjectorImpl.getSingleton(InjectorImpl.java:72)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.AuthMe.instantiateServices(AuthMe.java:237)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.AuthMe.initialize(AuthMe.java:212)
[20:50:49] [Server thread/WARN]: at fr.xephi.authme.AuthMe.onEnable(AuthMe.java:127)
[20:50:49] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:254)
[20:50:49] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:326)
[20:50:49] [Server thread/WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
[20:50:49] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugin(CraftServer.java:441)
[20:50:49] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugins(CraftServer.java:355)
[20:50:49] [Server thread/WARN]: at net.minecraft.server.v1_13_R2.MinecraftServer.l(MinecraftServer.java:608)
[20:50:49] [Server thread/WARN]: at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:570)
[20:50:49] [Server thread/WARN]: at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:431)
[20:50:49] [Server thread/WARN]: at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:316)
[20:50:49] [Server thread/WARN]: at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:786)
[20:50:49] [Server thread/WARN]: at java.lang.Thread.run(Thread.java:748)
[20:50:49] [Server thread/WARN]: Caused by: java.net.ConnectException: Connection refused (Connection refused)
[20:50:49] [Server thread/WARN]: at java.net.PlainSocketImpl.socketConnect(Native Method)
[20:50:49] [Server thread/WARN]: at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
[20:50:49] [Server thread/WARN]: at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
[20:50:49] [Server thread/WARN]: at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
[20:50:49] [Server thread/WARN]: at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
[20:50:49] [Server thread/WARN]: at java.net.Socket.connect(Socket.java:589)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.StandardSocketFactory.connect(StandardSocketFactory.java:211)
[20:50:49] [Server thread/WARN]: at com.mysql.jdbc.MysqlIO.(MysqlIO.java:301)
[20:50:49] [Server thread/WARN]: … 43 more
[20:50:49] [Server thread/WARN]: [AuthMe] Can’t initialize the MySQL database: [CommunicationsException]: Communications link failure
The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
[20:50:49] [Server thread/WARN]: [AuthMe] Please check your database settings in the config.yml file!
[20:50:49] [Server thread/WARN]: [AuthMe] Could not create data source: [CommunicationsException]: Communications link failure
The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
[20:50:49] [Server thread/WARN]: [AuthMe] Aborting initialization of AuthMe: [IllegalStateException]: Error during initialization of data source
[20:50:49] [Server thread/WARN]: [AuthMe] THE SERVER IS GOING TO SHUT DOWN AS DEFINED IN THE CONFIGURATION!
[20:50:49] [Server thread/INFO]: [AuthMe] Waiting for 0 tasks to finish
[20:50:49] [Server thread/INFO]: [AuthMe] AuthMe 5.5.1-SNAPSHOT-b2200 disabled!

Dodam także, że podczas próby usunięcia bazy danych (z poziomu panelu) stworzonej przez Pterodactyl wyskakuje błąd:

Whoops!
An error occurred while processing this request.

W configu podajesz: 127.0.0.1 czy ip vpsa?

Sprawdzałem najpierw na jedynym potem na drugim i na żadnym nie działa.

wpisz localhost zamiast np. IP Vps, mi kiedyś zadziałało :stuck_out_tongue:

Sprawdzałem też i nic :confused:

Tłumaczeniem Connection refused jest połączenie odrzucone - czyli coś jest z serwerem MySQL.
Sprawdź, na jaki adres nasłuchuje MySQL, ogólnie plugin AuthMe nie łapie połączenia - jakby serwer nie istniał.

Ten temat został automatycznie zamknięty 32 dni po ostatnim wpisie. Tworzenie nowych odpowiedzi nie jest już możliwe.