PHPMyAdmin problem z rozszerzeniami

Tagi: #<Tag:0x00007f8a3323ab80>

Cześć posiadam pewien problem ponieważ nie mogę zainstalować 2 rozszerzeń powinno być tak:
1
a jest
amam
wiecie może jak pomoc?

apt-get install php7.0-curl php7.0-mbstring -y && service apache2 restart

Zamień 7.0 swoją wersją PHP

1 polubienie

ja tylko dodam

1 polubienie

w przypadku tych dwóch pakietów i tak nie było by pytania czy na pewno :stuck_out_tongue:

1 polubienie

No właśnie chyba to mam :stuck_out_tongue:

**php7.3-curl is already the newest version (7.3.3-1+ubuntu16.04.1+deb.sury.org+1).
**php7.3-curl zaznaczony jako zainstalowany ręcznie.
**php7.3-mbstring is already the newest version (7.3.3-1+ubuntu16.04.1+deb.sury.org+1).
**php7.3-mbstring zaznaczony jako zainstalowany ręcznie.
**0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.

A jest taka możliwość ze phpmyadmin łapie inna wersje PHP bo niby mam 7.0 7.1 7.2 7.3
i czy gdzieś to można zmienic

ktoś coś może?

czasami najprostsze rozwiązania dają efekt…

a zrób reboot i zobacz

Mogę powiedzieć że nadal nie działa

Dodatki masz na wersję php 7.3, sprawdź czy na pewno domyślną wersją php jest 7.3 wpisując php -v

1 polubienie

root@vps7943:~# php -v

PHP 7.3.3-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Mar 7 2019 20:31:26) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.3.3, Copyright © 1998-2018 Zend Technologies
with Zend OPcache v7.3.3-1+ubuntu16.04.1+deb.sury.org+1, Copyright © 1999-2018, by Zend Technologies
root@vps7943:~#

Spróbuj odinstalować php7.3 oraz wszystkie dodatki na wersję 7.3 i zainstaluj php7.1 wraz z dodatkami na 7.1.

1 polubienie

A to ten jak to zrobić jaka komenda na to wraz z pakietami wszystkimi

apt-get purge php7.3 php7.3-mysqli php7.3-mbstring php7.3-curl
apt-get install php7.1 php7.1-mysqli php7.1-mbstring php7.1-curl
service apache2 restart

1 polubienie

Em dalej jest php 7.3
PHP 7.3.3-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Mar 7 2019 20:31:26) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.3.3, Copyright © 1998-2018 Zend Technologies
with Zend OPcache v7.3.3-1+ubuntu16.04.1+deb.sury.org+1, Copyright © 1999-2018, by Zend Technologies
root@vps7943:~/xbot#

Ja bym zrobił tak:

sudo apt purge php*
sudo apt install php7.1 php7.1-mysqli php7.1-mbstring php7.1-curl

A moge normalnie sobie zainstalować php7.3 i do niego wszystkie rzeczy?

Wtedy nie wpisuj tej dolnej komendy, bo zainstalują się pakiety PHP 7.2.

apt purge php* usuwa wszystkie, zainstalowane pakiety, których nazwa zawiera/zaczyna się na php.

czyli np

apt install php7.3 php7.3-mysqli php7.1-mbstring itp?

Nie można mieszać wersji w pakietach, inaczej będziesz dalej powtarzał błąd.

np:
proponuję choć pewno to jakiś ubu lub debian ( a nie distro rolling ) ale nie zaszkodzi co jakiś czas zrobić

apt update && apt upgrade

zawsze może coś nowego wpaść :wink: