Partycja swap nie działa


#1

Hej, ostatnio po zmianie oferty powiększyłem dysk za pomocą Gparteda i od tego czasu nie działa mi partycja swap.
Screenshot_7



#2

a próbowałeś włączyć jako root

swapon -a

a dla wyłączenia

swapoff -a

#3

Żadnej reakcji


#4

a w ogóle stworzyłeś partycję swap bo na tym co pokazałeś

jak się przyjrzałem nie widać swap po powiększeniu?

u mnie tak wygląda swap w /etc/fstab

UUID=75e60a4f-7ea8-4cff-9a1b-5363886102b2                                swap        swap    defaults    0    0

#5

Nie mogę znaleźć UUID dla udev


#6

Pokaż jak wygląda gotowa tablica partycji w gparted


#7

To dopiero gdzieś późnym wieczorem bo na razie zbyt dużo osób mam online


#8

To możesz nam pokazać również sudo parted --list, bez restartowania :wink:


#9

Screenshot_1


#10

dodatkowo i to w sumie by wystarczył co ma w /etc/fstab czy ma tam jakiś wpis o swap jak podałem w przykładzie jak u mnie wygląda…


#11


#12

no to masz jedną tylko główną partycję więc po powiększaniu coś poszło nie tak bo swap jest zawsze oddzielony
u mnie jest / główna partycja i oddzielnie swap


#13

W takim razie mogę to poprawić z poziomu konsoli czy muszę odpalić gparteda


#14

Tak w sumie możesz zawsze zamiast partycji użyć pliku swap. Moim zdaniem wygodniejsze.

https://support.rackspace.com/how-to/create-a-linux-swap-file/


#15

u mnie wygląda to tak:

# /etc/fstab: static file system information.
# <file system>                                 <mount point>   <type>  <options>       <dump>  <pass>
proc                                            /proc           proc    defaults        0       0
UUID=1d0d604b-6af0-4ea2-afc4-c61fb399e0be                                /        ext4    defaults    0    0
UUID=75e60a4f-7ea8-4cff-9a1b-5363886102b2                                swap        swap    defaults    0    0

to tak ku pamięci


ale jak napisał @Nieznajomy11 załatwisz to za pomocą piku swap


#16


:face_with_monocle: