Na jaką wersję Discourse jest dana wtyczka?

Witam, mam problem powiązany z wtyczkami do Discourse. Aczkolwiek nie wiem jak sprawdzić na jaką wersję jest napisany dany plugin. Tak, aby nie było potrzeby instalować i sprawdzać czy zadziała.

Jeżeli się tak nie da to może chociaż dostane informacje na jakiej wersji jest te forum?

Pozdrawiam

Generalnie ciężko odpowiedzieć na twoje pytanie.

Discourse to dość młody projekt który bardzo szybko się zmienia i generalnie nie ma takiego wyznacznika czy zadziała czy nie. Te forum jest aktualizowane do najnowszej wersji z gałęzi tests-passed średnio co tydzień. Ta gałąź jest zalecana i domyślnie ustawiona więc można powiedzieć że forum jest zawsze w najnowszej wersji.

Przy każdej aktualizacji dochodzą nowe commity git’a więc generalnie nawet jeśli będziesz próbować aktualizować discourse codziennie to będzie ciągle inny kod bo osoby ciągle tam coś dokładają, wystarczy popatrzeć że nie ma dnia bez zmian:

Co do wtyczek to proponuję używać tylko tych co są aktualizowane w miarę na bieżąco tak aby twórca mógł w kilka dni załatać błąd gdyż czasami powoduje to zatrzymanie całego forum, zdarzyło mi się to raz czy dwa.

Jak zobaczysz wtyczkę z powiedzmy początku 2016 roku czy nawet z 2015 i bez aktualizacji to już sugeruję sobie darować używanie tego bo szykują się kłopoty. Jeśli jest to coś naprawdę wartego uwagi to proponuję mieć drugie forum jako środowisko do sprawdzania przed modyfikacjami na produkcyjnym.

Mam duży problem z instalowaniem wtyczek. Dodałem wtyczkę zgodnie z tym co jest napisane tutaj: https://meta.discourse.org/t/install-a-plugin/19157
Po zakończeniu rebuildu forum pozostaje bez zmian. Może jest to wina tego, że jak nie zrobię czyszczenia przed budowaniem na nowo to mi się wyświetla: Not enough disk space?

Rebuild tą komendą?

cd /var/discourse
./launcher rebuild app

Jest ona poprawna.
Jeśli brakuje Ci miejsca na dysku to może jest używany stary kontener skoro nie może zostać stworzony nowy ze względu na brak miejsca.