FreeBSD 10 sshd_config

Witajcie! Mam problem mianowicie przy instalacji freebsd i konfiguracji sshd_config wszystko dziala. Konfiguruje config, dodaje PermitRootLogin itd… Restartuje serwer, a na ssh nadal nie moge sie polaczyc+caly plik sie wysypuje i jest poprostu pusty, a logowanie na ssh nie dziala. Da sie to jakos naprawic?

1 polubienie

Restartowałeś sshd/ssh?
Serwer odpowiada na porcie SSH?

1 polubienie

restartowalem. Wszystko dziala da sie polaczyc ale nie dziala logowanie sie haslem no i jest czysty plik sshd_config @Szymon

1 polubienie

Zobacz ten LINK

1 polubienie

@Szymon wiem tak robilem lecz… zawsze wysypuje sie sshd_config i nie ma nic w nim…

1 polubienie

Jaką komendą instalujesz ssh/sshd?
Jaką komendą restartujesz ssh/sshd?

1 polubienie

Nie instaluje poprostu edytuje sshd_config restartuje service ssh restart.
Czasami wlaczam i wylaczam vps @Szymon

1 polubienie

https://www.unixmen.com/enable-root-login-ssh-freebsd-10/

Dziwna sytuacja. Edytuj przez “ee” i zamiast restartować SSH reboot całego serwera.

2 polubienia

Robilem tak… ale nadal sie sypie.@Fallen

1 polubienie

Sprawdź jeszcze

/etc/rc.conf

Jest tam linijka odpowiedzialna za SSH

1 polubienie

@Fallen … robilem z twoim poradnikiem. wszystko tak samo moze nawet z 10 razy to robilem… ssh enable mam na yes.

1 polubienie

A stwórz nowego użytkownika i w tedy spróbuj się na niego zalogować.

@Fallen

//edit Nie jednak nie dziala…

Może to zabrzmi dziwnie ale sprawdzałeś że masz ping po obu stronach, prawda?
Przed próbą połączenia SSH warto to sprawdzić, mi się nie raz zdarzył ten błąd :slight_smile:

@SystemZ Tzn… mnie bardziej dziwi ze zawsze crashuje mi sshd_config… i nic nie da sie zrobic pusty plik i tyle… polaczyc sie moge do momentu wpisywania danych ponieważ config wysiadl= nie moge zalogowac sie przez haslo…

Proszę o odpowiedź mam ping/nie mam pingu, tyle wystarczy :slight_smile:
Pytam dla pewności bo nie do końca szczegółowo opisujesz.

1 polubienie

Mam… @SystemZ

@xNexT Nie musisz wpisywać @nick do każdej odpowiedzi wystarczy że jest przycisk Odpowiedz :smiley:

Problem rozwiazalem sam… do zamkniecia

Zamiast dopisywac PermitRootLogin i PasswordAuth poprostu usunalem # z Permit ktore juz sie zanjduje… pozniej nie uzywalem service ssh restart lecz reboot. Wszystko smigalo oprocz mysql :stuck_out_tongue:

1 polubienie

Miło byłoby gdybyś opisał w czym był problem, istotą forum jest pomoc sobie i jednocześnie innym gdy będą mieli ten sam problem, czasami jest fajne uczucie pomocy gdy ktoś znajdzie wątek z wyszukiwarki i rozwiąże to jego problem :slight_smile:

1 polubienie