[BungeeCord] Problem

Siema, zmieniłem wersje BungeeCorda, na HexaCord. Wszystko działa, gdy do folderu plugins nie są wgrane żadne pluginy. Lecz gdy wgram jakś plugin, to serwer się normalnie odplala, ale gdy ktokolwiek go spinguje, to wywala taki bład:

17:52:14 [SEVERE] Oct 19, 2016 5:52:14 PM io.netty.channel.ChannelInitializer exceptionCaught
WARNING: Failed to initialize a channel. Closing: [id: 0x2c4d59d0, L:/188.165.16.113:25577 - R:/5.172.237.102:13617]
java.lang.NoSuchMethodError: net.md_5.bungee.connection.InitialHandler.<init>(Lnet/md_5/bungee/api/ProxyServer;Lnet/md_5/bungee/api/config/ListenerInfo;)V
    at com.lite20.animatedMOTD.ConnectionReplacement.initChannel(ConnectionReplacement.java:59)
    at io.netty.channel.ChannelInitializer.initChannel(ChannelInitializer.java:113)
    at io.netty.channel.ChannelInitializer.handlerAdded(ChannelInitializer.java:105)
    at io.netty.channel.DefaultChannelPipeline.callHandlerAdded0(DefaultChannelPipeline.java:597)
    at io.netty.channel.DefaultChannelPipeline.access$000(DefaultChannelPipeline.java:44)
    at io.netty.channel.DefaultChannelPipeline$PendingHandlerAddedTask.execute(DefaultChannelPipeline.java:1387)
    at io.netty.channel.DefaultChannelPipeline.callHandlerAddedForAllHandlers(DefaultChannelPipeline.java:1122)
    at io.netty.channel.DefaultChannelPipeline.invokeHandlerAddedIfNeeded(DefaultChannelPipeline.java:647)
    at io.netty.channel.AbstractChannel$AbstractUnsafe.register0(AbstractChannel.java:506)
    at io.netty.channel.AbstractChannel$AbstractUnsafe.access$200(AbstractChannel.java:419)
    at io.netty.channel.AbstractChannel$AbstractUnsafe$1.run(AbstractChannel.java:478)
    at io.netty.util.concurrent.AbstractEventExecutor.safeExecute(AbstractEventExecutor.java:163)
    at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:418)
    at io.netty.channel.epoll.EpollEventLoop.run(EpollEventLoop.java:306)
    at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:873)
    at java.lang.Thread.run(Thread.java:745)

Nie mam pojęcia o co chodzi, bo się nie znam na programowaniu. Może wy znacie przyczynę. Oto całe logi serwera:

17:55:33 [INFO] Discovered module: ModuleSpec(name=reconnect_yaml, file=modules/reconnect_yaml.jar, provider=TravisCiModuleSource())
17:55:33 [INFO] Loaded plugin cmd_alert version git:cmd_alert:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Loaded plugin AnimMOTD version 1.3 by lite20
17:55:33 [INFO] Loaded plugin cmd_find version git:cmd_find:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Loaded plugin reconnect_yaml version git:reconnect_yaml:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Loaded plugin cmd_server version git:cmd_server:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Loaded plugin cmd_send version git:cmd_send:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Loaded plugin cmd_list version git:cmd_list:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [WARNING] Forced host server pvp is not defined
17:55:33 [INFO] Enabled plugin cmd_alert version git:cmd_alert:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] [AnimMOTD] Could not check for new version. This version might be outdated...
17:55:33 [INFO] Enabled plugin AnimMOTD version 1.3 by lite20
17:55:33 [INFO] Enabled plugin cmd_find version git:cmd_find:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Enabled plugin reconnect_yaml version git:reconnect_yaml:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Enabled plugin cmd_server version git:cmd_server:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Enabled plugin cmd_send version git:cmd_send:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [INFO] Enabled plugin cmd_list version git:cmd_list:1.10-SNAPSHOT:1570fa2:95 by SpigotMC
17:55:33 [SEVERE] Oct 19, 2016 5:55:33 PM io.netty.channel.DefaultChannelId defaultMachineId
WARNING: Failed to find a usable hardware address from the network interfaces; using random bytes: 1a:95:cc:4d:f3:6e:f0:7b

17:55:33 [INFO] Listening on /0.0.0.0:25577
17:55:55 [SEVERE] Oct 19, 2016 5:55:55 PM io.netty.channel.ChannelInitializer exceptionCaught
WARNING: Failed to initialize a channel. Closing: [id: 0xeda4a1a9, L:/188.165.16.113:25577 - R:/5.172.237.102:13614]
java.lang.NoSuchMethodError: net.md_5.bungee.connection.InitialHandler.<init>(Lnet/md_5/bungee/api/ProxyServer;Lnet/md_5/bungee/api/config/ListenerInfo;)V
    at com.lite20.animatedMOTD.ConnectionReplacement.initChannel(ConnectionReplacement.java:59)
    at io.netty.channel.ChannelInitializer.initChannel(ChannelInitializer.java:113)
    at io.netty.channel.ChannelInitializer.handlerAdded(ChannelInitializer.java:105)
    at io.netty.channel.DefaultChannelPipeline.callHandlerAdded0(DefaultChannelPipeline.java:597)
    at io.netty.channel.DefaultChannelPipeline.access$000(DefaultChannelPipeline.java:44)
    at io.netty.channel.DefaultChannelPipeline$PendingHandlerAddedTask.execute(DefaultChannelPipeline.java:1387)
    at io.netty.channel.DefaultChannelPipeline.callHandlerAddedForAllHandlers(DefaultChannelPipeline.java:1122)
    at io.netty.channel.DefaultChannelPipeline.invokeHandlerAddedIfNeeded(DefaultChannelPipeline.java:647)
    at io.netty.channel.AbstractChannel$AbstractUnsafe.register0(AbstractChannel.java:506)
    at io.netty.channel.AbstractChannel$AbstractUnsafe.access$200(AbstractChannel.java:419)
    at io.netty.channel.AbstractChannel$AbstractUnsafe$1.run(AbstractChannel.java:478)
    at io.netty.util.concurrent.AbstractEventExecutor.safeExecute(AbstractEventExecutor.java:163)
    at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:418)
    at io.netty.channel.epoll.EpollEventLoop.run(EpollEventLoop.java:306)
    at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:873)
    at java.lang.Thread.run(Thread.java:745)

Proszę o pomoc.

Jakie dokładnie pluginy próbowałeś wgrać?
Jakiej wersji hexacorda używasz? (/bungee)

Wgrałem przykładowo AnimMOTD.
Podam linka do GIT’a: https://github.com/HexagonMC/BungeeCord/releases
Pierwsza download, v96

AnimMOTD nie działa na 1.9 i 1.10 z tego co mi się wydaje.
Spróbuj wgrać ServerListPlus

java.lang.NoSuchMethodError: net.md_5.bungee.connection.InitialHandler

Zmiana w API, niekompatybilny plugin.
Poza tym animowane motd nie działa na 1.8.2 i nowszych.

OK, działa, lecz jak teraz ustawić ikonę serwera?

Wrzucić server-icon.png do folderu w którym jest .jar bungeecorda.