Bot do ts3

Witam,
Znacie może jakiegoś fajnego wielofunkcyjnego bota do ts3 za darmo? Fajnie jakby miał funkcje z osobami z najdłuższym połączeniem na serwerze itd.

Jasne! Łap najlepszego darmowego bota query GitHub - stalkerlifehack/qBot-your-TeamSpeak-automation: Its an application for teamspeak servers.

dzięki wielkie, wypróbuję go jeśli w ogóle uda mi się go wgrać :smiley:

Mam pytanie króciutkie, wiesz może czemu takie coś mi się wyświetla i jak to naprawić?
Starting!

  • instance was not started! Check the config file! (1)
  • instance was not started! Check the config file! (2)
  • instance was not started! Check the config file! (3)
  • instance was not started! Check the config file! (4)
  • instance was not started! Check the config file! (5)

Spróbuj skonfigurować poprawnie bota, możesz sprawdzić co jest nie tak wpisując
php core.php -i 1

wyświetliło mi się takie coś

PHP Fatal error: Array and string offset access syntax with curly braces is no longer supported in /home/ts3/teamspeak3-server_linux_amd64/qBot_v4.1/core.php on line 355

A jeśli chodzi o config to tylko pozmieniałem ip mojego vpsa od lvlup.pro i hasło query, które otrzymałem po zainstalowaniu ts3

Upewnij się, że masz wymaganą wersję php, nie ma żadnego błędu w configu.

wydaję mi się, że instalowałem taką jak w poradniku na githubie czyli 7.2. Da się jakoś sprawdzić tą którą mam w tym momencie jakąś komendą?

Z czego co widzę mam wersję PHP 8

 ts3@vps14331:~/teamspeak3-server_linux_amd64/qBot_v4.1$ php -v
PHP 8.0.5 (cli) (built: May  3 2021 11:30:38) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.5, Copyright (c) Zend Technologies
    with Zend OPcache v8.0.5, Copyright (c), by Zend Technologies
ts3@vps14331:~/teamspeak3-server_linux_amd64/qBot_v4.1$

A minimalną jest 7.2

Spróbuj zejść na 7.2-7.4

jak to zrobić, sory jestem laikiem w tych tematach

sudo apt purge php*
sudo apt install php7.2-cli php7.2-curl php7.2-mbstring php7.2-gd

zrobiłem to i pokazuję się samo
Starting!

ale bot na serwer nie wchodzi

Sprawdź:

php -ver

php core.php -i 1

root@vps14331:/home/ts3/teamspeak3-server_linux_amd64/qBot_v4.1# php -ver
PHP 7.2.34-21+ubuntu18.04.1+deb.sury.org+1 (cli) (built: May  1 2021 11:52:57) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.34-21+ubuntu18.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies

i

[->]Ładowanie potrzebnych plików...
[->]Sprawdzanie plików cache...
[->]Wybrano instancje numer:1
[ERROR] Nie możesz połączyć sie z serwerem! Host nie jest instancją teamspeak!
root@vps14331:/home/ts3/teamspeak3-server_linux_amd64/qBot_v4.1#

No i jesteś w domu, teraz popraw konfigurację tylko :slight_smile:

O co chodzi z tą linijką “Host nie jest instancją teamspeak!”?

A więc sprawdź poprawność konfiguracji połączenia do serwera