Błąd PHP | VPS KVM

vps
php
kvm
Tagi: #<Tag:0x00007f34395d3260> #<Tag:0x00007f34395d3120> #<Tag:0x00007f34395d2fb8>

#1

Tutaj macie zdjecie : https://scr.hu/3OdXLOq


Bład BZIP 2 i MySQL
Kombo MySQL MBSTRING BZIP2 SimpleXM | BŁĄD !
#2

Wersja systemu domyślnie instalowana na VPS KVM widocznie nie posiada w repozytoriach już php5, które jest przestarzałe i niedługo straci wsparcie. Czy aby na pewno nie możesz skorzystać z php7.2?


#3

To niewazne jaka werjsa PHP na 7.2 to samo


#4

Na ubuntu 16 to działa :

apt install php


#5

Nie działa


#6

wpisz taką komende

apt update && apt install php -y


#7

Dobra to działa
ale nadal nie działa Mysql extension


#8

apt install php-mysql


#9

Dzięki działa


#10

NMZC, jak szukałbyś technika za drobną opłatą to podbijaj śmiało


#11

w takim razie xD
:
E: Package ‘php5’ has no installation candidate
E: Package ‘php5-mysql’ has no installation candidate
E: Unable to locate package php5-curl
E: Package ‘php5-gd’ has no installation candidate
E: Package ‘php5-mcrypt’ has no installation candidate


#12

Nie php5 ponieważ go nie ma w repetytoriach ubuntu 16

zamiast

apt-get install php5 …

to

apt install php php-mysql php-gd php-mcrypt


#13

sudo: unable to resolve host vps7067


#14

bez sudo, a jak to wyskakuje to nic sie nie dzieje

apt install php php-mysql php-mcrypt php-gd -y


#15

zapomniałem dodać że to po restarcie apache2


#16

Ale jak to wyskoczy to nic sie nie dzieje, mi też to wyskakuje jak daje sudo do komend ale funkcjonuje normalnie


#17
sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install php5
sudo apt-get install php-mysql
sudo apt-get install php-curl
sudo apt-get install php-gd
sudo apt-get install php-mcrypt

#18

ale on php’a ma i po 2 nie polecam starych wersji php’a :expressionless:


#19

Bo instaluje bgpanel i zawsze szło wszystko ładnie z tymi komendami :

apt-get install sudo

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install -y apache2 php mysql-server php-mysql php-curl php-gd screen zip php-mcrypt <— Tutaj sie zaczyna problem

sudo service apache2 restart

sudo chown -R www-data:www-data /var/www


#20

bgpanel? co to podaj link.